You are here

Luminis 5.3 and Search

Submitted by melissa on Mon, 05/01/2017 - 15:40

Forums:

Hello Lumdev -
Just wondering if anyone out here has upgraded to Luminis 5 and has search working?

We are upgrading from Luminis IV to 5.3 and using the Ellucian LP5 theme.

As I understand it we need to set up Lucene. Just wondering what everyone else is using and if anyone has had success with Luminis 5 and Lucene search (or any other search solution)

TIA,
Melissa

Luminis Version:

I'm going through the same issue at this moment. Lucene would not work in our environment with admin and portal nodes on 2 different servers.

So on suggestion by support, I'm trying to get elasticsearch to work. Still running into issues with that, but I'll post back if I get it working.

As a side note, I was told that search will NOT work with targeted content, because the search feature is a liferay feature, not a luminis one.

Melissa,

I have the following configuration for our prod 5.3

ldap, admin, portal tiers 1-4

I also have a test instance of 5.3
1 ldap/admin server, portal tiers 1-2.

I have setup the Lucene indices on a share on the Admin server that all portal tiers mount. The search is functioning on both our PROD and TEST implementations of LP5.3. I have the following settings in the portal-ext.properties:

lucene.dir=/opt/luminisshared/lucene/
cluster.link.enabled=true
lucene.replicate.write=true

I used the LP Installation Guide for 5.3 on page 53. So I have gotten the Lucene indexing and search to work.