You are here

System Administration

Luminis Administration in general, maybe not a hack or mod but a tip on how to manage the system

Import pages question

Submitted by ruby-rube on Sat, 06/03/2017 - 09:13

Forums:

Hey Lum Devers!

I inadvertently imported a page lar file with permissions set in to come across in the lar file. Now I have roles from the other LP5 system on my sandbox, ex:Employee-LP-192. I can find all the roles from the other LP5, but how can I delete the foreign roles from my current system? When I go to control panel users, roles, there is no delete option in the action drop down.

Thank you,
Reuben

Luminis 4.3 ADFS 3.0 GCF

Submitted by aperture01 on Thu, 03/23/2017 - 10:25

Hi All,

We started using Luminis with a custom live@edu mod that allowed our students and staff to SSO onto live@edu. The service since turned into office365 and that connector broke. Thanks to the lumdev and Bill Ramsey we were able to use a GCF connector to login to ADFS thus regaining that functionality. Just recently we upgraded our ADFS 2.0 servers to ADFS 3.0 servers which has again broke this connector. Has anyone used GCF on Lum 4 to login to SSO to office 365?

Help! Chrome Update and Luminis IV

Submitted by blackwellbs on Mon, 01/30/2017 - 12:52

Google pushed out a Chrome update last week (version 56.0.2924). As Chrome auto-updates, we have many reports of Luminis IV not working. The user gets:

Sorry, but uPortal encountered an error that is preventing it from rendering. The error must be corrected by system administrators.

My Chrome install was still sitting at the previous version and worked fine. I manually updated to this latest version and sure enough I get the error as well. Clearing cache or removing/re-installing does nothing.

Anyone have some recommendations? The error in cp.log is:

old luminis 4 bookmarks in luminis 5

Submitted by bergesonm on Tue, 01/10/2017 - 16:05

Forums:

Hi,

We are seeing an issue where new students people in the system (new to luminis 5 this month) use old luminis 4 book marks and get prompted for a username and password and then set up security questions and then get a page not found error.

The example could be like this https://domain/cp/home/check/pre

The system takes it and will fail after redirecting after the student sets up their security questions with a 404 page not found.

Any way to mitigate this?

Thanks,

Mitch

Luminis 5 Portlets

Submitted by bergesonm on Tue, 03/22/2016 - 16:41

Forums:

Hi,

We are currently getting ready to move to the Luminis 5 Portal. We currently integrate with National Student Clearinghouse Self-Service Site using a Java Servlet and passing the Banner ID to them that way. With Luminis 5, has anyone developed a working Portlet with them, or something similar for SSO? Any help would be appreciated. Also, if there exists any getting starting guides with Portlets that would be helpful too.

Thank you,

Mitch

Adding security to pages hosted on the portal server

Submitted by rdenyar on Thu, 11/19/2015 - 08:30

Forums:

We have a couple pages saved within the theme folder that our CMS has access to allowing the content owners to make updates. Having this ‘local’ folder is working perfectly for us except for one drawback. It would be preferred to require users to login to the portal before being allowed to view these hosted pages.

Has anyone ever looked into securing pages hosted on the portal? I was hoping to be able to use Tomcat filtering to confirm the user was authenticated via CAS before serving up the pages.

Subscribe to RSS - System Administration